June 19, 2018, 05:32:16 PM
collapse

* Site Menu

How To Emulate An Outdated Mod

Be warned!!! Emulation does not always work! Also, it can cause problems if you upgrade your version of SMF and do not uninstall the emulated mod(s) first! New code may be introduced into the new version of SMF you are upgrading to that may conflict with emulated mods and can possibly render your site unusable or otherwise cause problems! Proceed with caution and at your own risk!!!

That being said, emulation/emulating is very easy to do. Yes, it sounds like it's hard or a lot of work is involved but it isn't. Let's say, for example, you want to install the "I Look Stupid" mod (yes, I made that up) but it was created for SMF 2 RC2 and your forum's version is currently at SMF 2.0.2. If you try to install it normally you'll get a message telling you that it will not work with your version of SMF (remember you have SMF 2.0.2 installed). But, you can force Packages to think you have SMF 2 RC2 installed.  ???

Go to "Browse Packages". At the bottom of the page, you'll see the "Advanced" link as shown in the image below. Click it.



You'll see a new box has been added to the "Browse Packages" page directly under the "Advanced" link. This box will allow you to tell Packages what version of SMF to emulate....but you must know what version to emulate. Just enter the version in the text field provided then click "Save" as shown in the following image.



Now you can install the SMF 2 RC2 mod as if you actually have SMF 2 RC2 installed.

When you are done (and if everything works ok) you should click "Revert" as shown in this image.



This will reset Packages back to SMF 2.0.2 or whatever your current version is. If you do not click "Revert" and try to install a mod for your current version (SMF 2.0.2 in this example) it will not work!

Also, after you revert, you will no longer see "Uninstall" to the right of that mod as shown.



You must change the emulate setting back to SMF 2 RC2 (or whatever version you were trying to emulate) to see it again so that you can uninstall it.
Page created in 0.024 seconds with 17 queries.